es 6.6.2.tar.gz
修改后需要重启es才能生效。 不修改的话ES启动的时候会报错,原因是elasticsearch用户拥有的内存权限太小,至少需要262144。max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]。
补充内容:
-Xms 堆内存的最小大小,默认为物理内存的1/64 -Xmx 堆内存的最大大小,默认为物理内存的1/4 -Xmn 堆内新生代的大小。通过这个值也可以得到老生代的大小:-Xmx减去-Xmn不要用root用户启动es 创建用户
useradd xxx echo "Password" | passwd xxx --stdin # 启动 bin/elasticsearch # 后台启动 bin/elasticsearch -d # 启动日志在logs文件夹中下载后解压缩到elasticsearch的plugins目录下 ik分词器
POST /_analyze { “analyzer”: “ik_smart”, “text”: “test中文刘德华”} 拼音分词器 GET /medcl/_analyze { “text”: [“刘德华”], “analyzer”: “pinyin_analyzer” }
注意下载的分词器要和es的版本对应
