本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
如果密码合法,输出Your password is wan mei.; 如果密码太短,不论合法与否,都输出Your password is tai duan le.; 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.; 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.; 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。
输入样例:
5
123s
zheshi
.wodepw
1234.5678
WanMei23333
pass
*word
.6
输出样例:
Your password is tai duan le
.
Your password needs shu zi
.
Your password needs zi mu
.
Your password is wan mei
.
Your password is tai luan le
.
参考代码:
#include<iostream>
#include<ctype.h>
#include<cstdio>
#include<cstring>
using namespace std
;
bool IsIllegalCh(char s
[],int len
);
bool IsOnlyAl(char s
[],int len
);
bool IsOnlyNum(char s
[],int len
);
int main()
{
int i
,N
;
scanf("%d\n",&N
);
char s
[81];
int len
=0;
for(i
=0;i
<N
;i
++)
{
cin
.getline(s
,sizeof(s
));
len
=strlen(s
);
if(len
<6)
printf("Your password is tai duan le.\n");
else if(IsIllegalCh(s
,len
))
printf("Your password is tai luan le.\n");
else if(IsOnlyAl(s
,len
))
printf("Your password needs shu zi.\n");
else if(IsOnlyNum(s
,len
))
printf("Your password needs zi mu.\n");
else
printf("Your password is wan mei.\n");
}
return 0;
}
bool IsIllegalCh(char s
[],int len
)
{
int flag
=1;
for(int i
=0;i
<len
;i
++)
{
if(!isalnum(s
[i
])&&s
[i
]!='.')
flag
=0;
}
if(!flag
) return true;
else return false;
}
bool IsOnlyAl(char s
[],int len
)
{
int flag
=1;
for(int i
=0;i
<len
;i
++)
{
if(isdigit(s
[i
])) flag
=0;
}
if(flag
)
return true;
else
return false;
}
bool IsOnlyNum(char s
[],int len
)
{
int flag
=1;
for(int i
=0;i
<len
;i
++)
{
if(isalpha(s
[i
])) flag
=0;
}
if(flag
)
return true;
else
return false;
}
思路:
这题思路很简单,但是有些点需要注意。
读入一行字符串包括空格,所以这里用cin.getline()函数,gets()函数因为在PAT C++编译器中编译错误,这里不要使用;这题可以使用C++中的字符处理函数会使代码更加简洁,这些库函数在ctype中声明,主要有: