【题目描述】
输入两个字符串,验证其中一个串是否为另一个串的子串。
【输入】
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
【输出】
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2) 否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1) 否则,输出 No substring。
【样例输入】
abc
dddncabca
【样例输出】
abc is substring of dddncabca
源代码
#include <iostream>
#include <cstring>
char str1
[201], str2
[201];
int main() {
int len1
, len2
;
gets(str1
); gets(str2
);
len1
= strlen(str1
);
len2
= strlen(str2
);
if (len1
>= len2
) {
if (strstr(str1
, str2
) != NULL) {
printf("%s is substring of %s", str2
, str1
);
} else {
printf("No substring");
}
} else {
if (strstr(str2
, str1
) != NULL) {
printf("%s is substring of %s", str1
, str2
);
} else {
printf("No substring");
}
}
return 0;
}